最近碰到一個問題很怪
user一直反應使用word 2007編輯檔案
使用doc的格式會一直出現記憶体不足的error
改用docx後到目前為止沒再發生
不知如何解釋
2012/03/24
2012/03/22
多網卡bind同一個ip的方法
http://blog.secaserver.com/2011/11/centos-bonding-multiple-network-interface-card-nics/
http://www.how2centos.com/centos-6-channel-bonding/
proxmox 使用
http://pve.proxmox.com/wiki/Bond_configuration_(Video)
只有mode 6 guest os會通
http://yu-minspace.blogspot.com/2008/02/linux-bonding-lnux-kernel-2.html
所以只有mode 1及 mode 6可以使用 特別注意
否則guest os網路不會通
http://blog.secaserver.com/2011/11/centos-bonding-multiple-network-interface-card-nics/
http://www.how2centos.com/centos-6-channel-bonding/
proxmox 使用
http://pve.proxmox.com/wiki/Bond_configuration_(Video)
只有mode 6 guest os會通
http://yu-minspace.blogspot.com/2008/02/linux-bonding-lnux-kernel-2.html
所以只有mode 1及 mode 6可以使用 特別注意
否則guest os網路不會通
2012/03/21
今天在設定route-map
因為久沒下
所以有點忘了
記錄一下
1. 一定要先下
sdm prefer routing
這是隱藏指令 很重要
2. 再來設定 access-list
ip access-list extended 101
deny ip 192.168.0.0 0.0.255.255 host 10.0.0.3 (4786696 matches)
permit ip 192.168.0.0 0.0.255.255 any
3.設定route-map
route-map test permit 10
match ip address 101
set ip next-hop 10.0.0.1
4. 再把指令下到port 上或vlan上
ip policy route-map test
http://harlemhsu.pixnet.net/blog/post/20501380-%E8%A7%A3%E6%94%BE-cisco-3560-%E7%9A%84-ip-policy-route-map-(%E7%AD%96%E7%95%A5%E6%80%A7%E8%B7%AF%E7%94%B1)-
因為久沒下
所以有點忘了
記錄一下
1. 一定要先下
sdm prefer routing
這是隱藏指令 很重要
2. 再來設定 access-list
ip access-list extended 101
deny ip 192.168.0.0 0.0.255.255 host 10.0.0.3 (4786696 matches)
permit ip 192.168.0.0 0.0.255.255 any
3.設定route-map
route-map test permit 10
match ip address 101
set ip next-hop 10.0.0.1
4. 再把指令下到port 上或vlan上
ip policy route-map test
http://harlemhsu.pixnet.net/blog/post/20501380-%E8%A7%A3%E6%94%BE-cisco-3560-%E7%9A%84-ip-policy-route-map-(%E7%AD%96%E7%95%A5%E6%80%A7%E8%B7%AF%E7%94%B1)-
2012/03/18
2012/03/11
python 印出程式執行時間
import time
# 記錄開始時間 Record start time
tStart = time.time()
# 記錄結束時間 Record stop time
tStop = time.time()
print(tStop - tStart)
http://whhnote.blogspot.com/2010/10/python.html
2012/03/10
想研究一下python 畫圖
先安裝
http://my.opera.com/taiwanmonkey/blog/2012/02/19/python-2
範例
# -*- coding: cp950 -*-
import matplotlib.pyplot as plt
#以直線畫出一個三角形
plt.plot([1,20,20,1],[1,1,20,1],color="green",linewidth=5)
#畫點 r表示紅色 o表示圓形
#詳細在http://matplotlib.sourceforge.net/api/pyplot_api.html#matplotlib.pyplot.plot
for i in range(10):
plt.plot([2],[i*2],'ro')
#plt.plot([i],[i*2],'r1')
#plt.plot([i],[i*3],'r2')
#plt.plot([i],[i*4],'r3')
#plt.plot([i],[i*5],'r4')
#plt.plot([i])
plt.axis([-10,30,-10,30])
plt.xlabel('x numbers')
plt.ylabel('y numbers')
plt.show()
http://blog.rexzhao.com/category/matplotlib
先安裝
http://my.opera.com/taiwanmonkey/blog/2012/02/19/python-2
範例
# -*- coding: cp950 -*-
import matplotlib.pyplot as plt
#以直線畫出一個三角形
plt.plot([1,20,20,1],[1,1,20,1],color="green",linewidth=5)
#畫點 r表示紅色 o表示圓形
#詳細在http://matplotlib.sourceforge.net/api/pyplot_api.html#matplotlib.pyplot.plot
for i in range(10):
plt.plot([2],[i*2],'ro')
#plt.plot([i],[i*2],'r1')
#plt.plot([i],[i*3],'r2')
#plt.plot([i],[i*4],'r3')
#plt.plot([i],[i*5],'r4')
#plt.plot([i])
plt.axis([-10,30,-10,30])
plt.xlabel('x numbers')
plt.ylabel('y numbers')
plt.show()
http://blog.rexzhao.com/category/matplotlib
2012/03/08
2012/03/03
今天在找要如何用python登入apache的認証網頁
找到httplib2
http://code.google.com/p/httplib2/
範例如下
import base64
import httplib2
h = httplib2.Http()
auth = base64.encodestring( 'id' + ':' + 'password' )
resp, content = h.request(
'http://10.0.0.56/all/',
'GET',
headers = { 'Authorization' : 'Basic ' + auth }
)
print resp #傳回html的標頭
print content #傳回html的內容
2012/03/02
2012/03/01
今天一台vm出現disk空間不夠的問題
參考以下的資料
搞定
改完後記得再用gparted 調整分割大小
修改虛擬機鏡像大小(qcow2/raw resize)
不多說,直接看
創建一個鏡像文件,大小1G,格式是qcow2
muxueqz@muxueqz /tmp $ qemu-img create -f qcow2 t.qcow2 1G
Formatting 't.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=0
查看鏡像文件實際佔用空間
muxueqz@muxueqz /tmp $ ls -alh t.qcow2
-rw-r--r-- 1 muxueqz muxueqz 193K 8月31 13:18 t.qcow2
查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 1.0G (1073741824 bytes)
disk size: 136K
cluster_size: 65536
加1G(resize +)
muxueqz@muxueqz /tmp $ qemu-img resize t.qcow2 +1G
Image resized.
再查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 2.0G (2147483648 bytes)
disk size: 140K
cluster_size: 65536
減1G(resize -)
muxueqz@muxueqz /tmp $ qemu-img resize t.qcow2 -- 2G
qemu-img: This image format does not support resize
!!!qcow2只能加不能減!
再查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 2.0G (2147483648 bytes)
disk size: 140K
cluster_size: 65536
果然沒變
再試試改變raw格式的大小(resize raw)
同樣先創建1G大小的raw
muxueqz@muxueqz /tmp $ qemu-img create -f raw t.raw 1G
Formatting 't.raw', fmt=raw size=1073741824
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format : raw
virtual size: 1.0G (1073741824 bytes)
disk size: 1.0M
可以看出raw要比qcow2多佔一些空間。
加1G
muxueqz@muxueqz /tmp $ qemu-img resize t.raw -- +1G
Image resized.
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format: raw
virtual size: 2.0G (2147483648 bytes )
disk size: 2.0M
減1G(resize -)
muxueqz@muxueqz /tmp $ qemu-img resize t.raw -- -1G
Image resized.
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format: raw
virtual size: 1.0G (1073741824 bytes )
disk size: 1.0M
http://www.linuxzh.org/Linux/qemu_resize.html
參考以下的資料
搞定
改完後記得再用gparted 調整分割大小
修改虛擬機鏡像大小(qcow2/raw resize)
不多說,直接看
創建一個鏡像文件,大小1G,格式是qcow2
muxueqz@muxueqz /tmp $ qemu-img create -f qcow2 t.qcow2 1G
Formatting 't.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=0
查看鏡像文件實際佔用空間
muxueqz@muxueqz /tmp $ ls -alh t.qcow2
-rw-r--r-- 1 muxueqz muxueqz 193K 8月31 13:18 t.qcow2
查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 1.0G (1073741824 bytes)
disk size: 136K
cluster_size: 65536
加1G(resize +)
muxueqz@muxueqz /tmp $ qemu-img resize t.qcow2 +1G
Image resized.
再查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 2.0G (2147483648 bytes)
disk size: 140K
cluster_size: 65536
減1G(resize -)
muxueqz@muxueqz /tmp $ qemu-img resize t.qcow2 -- 2G
qemu-img: This image format does not support resize
!!!qcow2只能加不能減!
再查看qcow2信息
muxueqz@muxueqz /tmp $ qemu-img info t.qcow2
image: t.qcow2
file format: qcow2
virtual size: 2.0G (2147483648 bytes)
disk size: 140K
cluster_size: 65536
果然沒變
再試試改變raw格式的大小(resize raw)
同樣先創建1G大小的raw
muxueqz@muxueqz /tmp $ qemu-img create -f raw t.raw 1G
Formatting 't.raw', fmt=raw size=1073741824
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format : raw
virtual size: 1.0G (1073741824 bytes)
disk size: 1.0M
可以看出raw要比qcow2多佔一些空間。
加1G
muxueqz@muxueqz /tmp $ qemu-img resize t.raw -- +1G
Image resized.
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format: raw
virtual size: 2.0G (2147483648 bytes )
disk size: 2.0M
減1G(resize -)
muxueqz@muxueqz /tmp $ qemu-img resize t.raw -- -1G
Image resized.
muxueqz@muxueqz /tmp $ qemu-img info t.raw
image: t.raw
file format: raw
virtual size: 1.0G (1073741824 bytes )
disk size: 1.0M
http://www.linuxzh.org/Linux/qemu_resize.html
訂閱:
文章 (Atom)